Last change
on this file since 3147 was
3089,
checked in by landauf, 15 years ago
|
merged map branch back to trunk
|
-
Property svn:eol-style set to
native
|
File size:
714 bytes
|
Rev | Line | |
---|
[2838] | 1 | pkgname=orxonox-svn |
---|
| 2 | pkgver=2826 |
---|
| 3 | pkgrel=1 |
---|
| 4 | pkgdesc="Orxonox - the hottest 3D action shooter ever to exist" |
---|
| 5 | arch=('i686' 'x86_64') |
---|
| 6 | url="http://www.orxonox.net/" |
---|
| 7 | license=('GPL') |
---|
| 8 | depends=('ogre-branch-1.4' 'tcl' 'cegui' 'enet' 'boost' 'freealut' 'libvorbis') |
---|
| 9 | makedepends=('subversion' 'cmake') |
---|
| 10 | conflicts=('orxonox') |
---|
| 11 | provides=('orxonox') |
---|
| 12 | source=() |
---|
| 13 | md5sums=() |
---|
| 14 | |
---|
| 15 | _svntrunk=http://svn.orxonox.net/orxonox/trunk |
---|
| 16 | _svnmedia=http://svn.orxonox.net/data/media |
---|
| 17 | _svnmod=orxonox |
---|
| 18 | |
---|
| 19 | build() { |
---|
| 20 | cd $startdir/src |
---|
| 21 | svn co $_svntrunk $_svnmod |
---|
| 22 | cd $_svnmod |
---|
| 23 | svn co $_svnmedia |
---|
| 24 | mkdir build |
---|
| 25 | cd build |
---|
| 26 | msg "Starting build..." |
---|
| 27 | cmake .. |
---|
| 28 | make || return 1 |
---|
| 29 | make DESTDIR=${startdir}/pkg install |
---|
| 30 | #rm -rf $startdir/src/$_svnmod/build |
---|
| 31 | } |
---|
Note: See
TracBrowser
for help on using the repository browser.