Last change
on this file since 29 was
29,
checked in by landauf, 17 years ago
|
updated boost from 1_33_1 to 1_34_1
|
File size:
1.4 KB
|
Line | |
---|
1 | #!/usr/bin/make -f |
---|
2 | # Sample debian/rules that uses debhelper. |
---|
3 | # This file is public domain software, originally written by Joey Hess. |
---|
4 | |
---|
5 | # Uncomment this to turn on verbose mode. |
---|
6 | #export DH_VERBOSE=1 |
---|
7 | |
---|
8 | build: |
---|
9 | clean: |
---|
10 | binary-arch: |
---|
11 | |
---|
12 | binary-indep: |
---|
13 | dh_testdir |
---|
14 | dh_testroot |
---|
15 | |
---|
16 | dh_clean -k |
---|
17 | dh_installdirs usr/share/boost-build etc |
---|
18 | |
---|
19 | # Add here commands to install the package into debian/<packagename> |
---|
20 | (tar --exclude-from debian/excludes -cpf - * ) | (cd `pwd`/debian/tmp/usr/share/boost-build && tar xpf - ) |
---|
21 | chmod a-x -R `pwd`/debian/tmp/usr/share/boost-build |
---|
22 | |
---|
23 | dh_installchangelogs |
---|
24 | dh_installdocs -XCVS |
---|
25 | mv `pwd`/debian/tmp/usr/share/doc/boost-build/index_v2.html `pwd`/debian/tmp/usr/share/doc/boost-build/index.html |
---|
26 | |
---|
27 | (tar --exclude make --exclude CVS -cpf - example/* ) | ( cd `pwd`/debian/tmp/usr/share/doc/boost-build && tar xpf - ) |
---|
28 | |
---|
29 | sed 's/# using gcc ;/using gcc ;/' user-config.jam > `pwd`/debian/tmp/etc/site-config.jam |
---|
30 | |
---|
31 | # dh_install |
---|
32 | # dh_installmenu |
---|
33 | # dh_installdebconf |
---|
34 | # dh_installlogrotate |
---|
35 | # dh_installemacsen |
---|
36 | # dh_installcatalogs |
---|
37 | # dh_installpam |
---|
38 | # dh_installmime |
---|
39 | # dh_installinit |
---|
40 | # dh_installcron |
---|
41 | # dh_installinfo |
---|
42 | # dh_undocumented |
---|
43 | dh_installman |
---|
44 | dh_link |
---|
45 | dh_compress |
---|
46 | dh_fixperms |
---|
47 | # dh_perl |
---|
48 | # dh_python |
---|
49 | # dh_makeshlibs |
---|
50 | dh_installdeb |
---|
51 | dh_gencontrol |
---|
52 | dh_md5sums |
---|
53 | dh_builddeb |
---|
54 | |
---|
55 | binary: binary-indep binary-arch |
---|
56 | .PHONY: build clean binary-indep binary-arch binary install |
---|
Note: See
TracBrowser
for help on using the repository browser.