Last change
on this file since 6883 was
5822,
checked in by bensch, 19 years ago
|
orxonox/trunk: merged branches/network to the trunk
merged with command:
svn merge -r 5505:HEAD branches/network trunk
conflicts resolved in favor of the trunk (as always
also fixed a typo in the #include "SDL_tread.h"
|
File size:
1.5 KB
|
Line | |
---|
1 | # Copyright 1999-2005 Gentoo Foundation |
---|
2 | # Distributed under the terms of the GNU General Public License v2 |
---|
3 | # $Header: $ |
---|
4 | |
---|
5 | inherit eutils games |
---|
6 | |
---|
7 | DATA_VERSION=83 |
---|
8 | |
---|
9 | DESCRIPTION="orxonox is an open-source 3D-action game programmed in C++, OpenGL, OpenAL and SDL" |
---|
10 | HOMEPAGE="http://www.orxonox.net" |
---|
11 | SRC_URI="http://www.orxonox.net/files/snapshots/${P}-${PR}.tar.bz2 |
---|
12 | http://www.orxonox.net/files/snapshots/${PN}-data-r${DATA_VERSION}.tar.bz2" |
---|
13 | LICENSE="GPL-2" |
---|
14 | SLOT="0" |
---|
15 | KEYWORDS="x86" |
---|
16 | IUSE="gtk+-2" |
---|
17 | |
---|
18 | DEPEND="virtual/opengl |
---|
19 | virtual/x11 |
---|
20 | media-libs/openal |
---|
21 | media-libs/libsdl |
---|
22 | media-libs/sdl-image |
---|
23 | media-libs/sdl-ttf |
---|
24 | media-libs/sdl-net |
---|
25 | media-libs/glew" |
---|
26 | |
---|
27 | # Run-time dependencies, same as DEPEND if RDEPEND isn't defined: |
---|
28 | #RDEPEND="" |
---|
29 | S=${WORKDIR}/${P} |
---|
30 | |
---|
31 | src_unpack() { |
---|
32 | unpack ${P}-${PR}.tar.bz2 |
---|
33 | cd "${S}" |
---|
34 | unpack ${PN}-data-r${DATA_VERSION}.tar.bz2 |
---|
35 | } |
---|
36 | |
---|
37 | src_compile() { |
---|
38 | egamesconf || die |
---|
39 | |
---|
40 | emake || die "emake failed" |
---|
41 | } |
---|
42 | |
---|
43 | src_install() { |
---|
44 | make DESTDIR=${D} install || die |
---|
45 | |
---|
46 | dodir ${GAMES_DATADIR}/${PN} |
---|
47 | cp -r data/* ${D}/${GAMES_DATADIR}/${PN}/ \ |
---|
48 | || die "data copy failed" |
---|
49 | |
---|
50 | dodoc AUTHORS ChangeLog README |
---|
51 | |
---|
52 | prepgamesdirs |
---|
53 | |
---|
54 | #make \ |
---|
55 | # prefix=${D}/usr \ |
---|
56 | # mandir=${D}/usr/share/man \ |
---|
57 | # infodir=${D}/usr/share/info \ |
---|
58 | # libdir=${D}/usr/$(get_libdir) \ |
---|
59 | # install || die |
---|
60 | |
---|
61 | #einstall || die |
---|
62 | } |
---|
63 | |
---|
64 | pkg_postinst() { |
---|
65 | games_pkg_postinst |
---|
66 | } |
---|
Note: See
TracBrowser
for help on using the repository browser.