1 | # Copyright 1999-2005 Gentoo Foundation |
---|
2 | # Distributed under the terms of the GNU General Public License v2 |
---|
3 | # $Header: $ |
---|
4 | |
---|
5 | # original comes from http://www.orxonox.net/ , 2006-02-11 |
---|
6 | # modified/tested by S. Fuchs, http://srf.ch/ , 2006-02-11 |
---|
7 | # |
---|
8 | # put this ebuild into your portage overlay: games-action/orxonox/ |
---|
9 | # see /etc/make.conf to configure the portage overlay. |
---|
10 | # then cd into that games-action/orxonox/ directory and do: |
---|
11 | # $ ebuild orxonox-0.3.2_alpha-r7122.ebuild digest |
---|
12 | # $ emerge -av --oneshot orxonox |
---|
13 | # to install it (ommit the --oneshot to get an entry in your world file). |
---|
14 | # |
---|
15 | # put http://fuchs.dnsalias.net/public/orxonox/orxonox-0.3.2_alpha-r7122.tar.bz2 |
---|
16 | # manually into your distfiles directory (usually /usr/portage/distfiles) |
---|
17 | # if it's not available from http://www.orxonox.net/files/snapshots/ |
---|
18 | |
---|
19 | inherit eutils games |
---|
20 | |
---|
21 | DATA_VERSION=372 |
---|
22 | |
---|
23 | DESCRIPTION="orxonox is an open-source 3D-action game programmed in C++, OpenGL, OpenAL and SDL" |
---|
24 | HOMEPAGE="http://www.orxonox.net" |
---|
25 | SRC_URI="http://www.orxonox.net/files/snapshots/${P}-${PR}.tar.bz2 |
---|
26 | http://www.orxonox.net/files/snapshots/${PN}-data-r${DATA_VERSION}.tar.bz2" |
---|
27 | LICENSE="GPL-2" |
---|
28 | SLOT="0" |
---|
29 | KEYWORDS="x86" |
---|
30 | IUSE="gtk+-2" |
---|
31 | |
---|
32 | DEPEND="virtual/opengl |
---|
33 | virtual/x11 |
---|
34 | media-libs/openal |
---|
35 | media-libs/libsdl |
---|
36 | media-libs/sdl-image |
---|
37 | media-libs/sdl-ttf |
---|
38 | media-libs/sdl-net |
---|
39 | media-libs/glew" |
---|
40 | |
---|
41 | # Run-time dependencies, same as DEPEND if RDEPEND isn't defined: |
---|
42 | #RDEPEND="" |
---|
43 | S=${WORKDIR}/${P} |
---|
44 | |
---|
45 | src_unpack() { |
---|
46 | unpack ${P}-${PR}.tar.bz2 |
---|
47 | cd "${S}" |
---|
48 | unpack ${PN}-data-r${DATA_VERSION}.tar.bz2 |
---|
49 | } |
---|
50 | |
---|
51 | src_compile() { |
---|
52 | egamesconf || die |
---|
53 | |
---|
54 | emake || die "emake failed" |
---|
55 | } |
---|
56 | |
---|
57 | src_install() { |
---|
58 | make DESTDIR=${D} install || die |
---|
59 | |
---|
60 | dodir ${GAMES_DATADIR}/${PN} |
---|
61 | cp -r data/* ${D}/${GAMES_DATADIR}/${PN}/ \ |
---|
62 | || die "data copy failed" |
---|
63 | |
---|
64 | dodoc AUTHORS ChangeLog README |
---|
65 | |
---|
66 | prepgamesdirs |
---|
67 | |
---|
68 | #make \ |
---|
69 | # prefix=${D}/usr \ |
---|
70 | # mandir=${D}/usr/share/man \ |
---|
71 | # infodir=${D}/usr/share/info \ |
---|
72 | # libdir=${D}/usr/$(get_libdir) \ |
---|
73 | # install || die |
---|
74 | |
---|
75 | #einstall || die |
---|
76 | } |
---|
77 | |
---|
78 | pkg_postinst() { |
---|
79 | games_pkg_postinst |
---|
80 | } |
---|