Last change
on this file since 4764 was
4757,
checked in by bensch, 19 years ago
|
orxonox/trunk: added orxonox.ebuild, that is a bug in itself
|
File size:
755 bytes
|
Rev | Line | |
---|
[4757] | 1 | # Copyright 1999-2005 Gentoo Foundation |
---|
| 2 | # Distributed under the terms of the GNU General Public License v2 |
---|
| 3 | # $Header: $ |
---|
| 4 | |
---|
| 5 | |
---|
| 6 | inherit games |
---|
| 7 | |
---|
| 8 | DESCRIPTION="orxonox is an open-source vertical scroller game programmed in C++, OpenGL, OpenAL and SDL." |
---|
| 9 | HOMEPAGE="http://www.orxonox.ethz.ch" |
---|
| 10 | SRC_URI="http://www.orxonox.ethz.ch/files/snapshots/snapshots/orxonox-0.2.3-pre-alpha%234756.tar.bz2" |
---|
| 11 | |
---|
| 12 | DEPEND="virtual/opengl |
---|
| 13 | virtual/x11 |
---|
| 14 | media-libs/openal |
---|
| 15 | media-libs/libsdl |
---|
| 16 | media-libs/sdl-image |
---|
| 17 | media-libs/sdl-ttf" |
---|
| 18 | |
---|
| 19 | |
---|
| 20 | KEYWORDS="x86" |
---|
| 21 | LICENSE="GPL-2" |
---|
| 22 | SLOT="0" |
---|
| 23 | IUSE="" |
---|
| 24 | |
---|
| 25 | |
---|
| 26 | src_unpack() { |
---|
| 27 | unpack ${A} |
---|
| 28 | cd "${S}" |
---|
| 29 | } |
---|
| 30 | |
---|
| 31 | src_install() { |
---|
| 32 | dogamesbin orxonox || die "dogamesbin failed" |
---|
| 33 | dodir "${GAMES_DATADIR}/${PN}" |
---|
| 34 | } |
---|
Note: See
TracBrowser
for help on using the repository browser.